您现在的位置是:首页 > Mac的MAMP集成环境下安装Swoole

Mac的MAMP集成环境下安装Swoole

默认 2019-10-11 22:23 236人围观 来源:原创
php  
简介Swoole现在几乎是PHP开发必不可少的了,但是它的安装一直比较复杂。

1、首先我们要确保终端下调用的是MAMP的PHP而不是Mac系统自带的,通过php --ini来辨别,如果php.ini文件路径里含有Mamp则是有效的,否则请在~/.bash_profile里添加:具体的PHP版本请参考自己的实际情况。

 export PATH=/Applications/MAMP/bin/php/php7.3.8/bin:$PATH

2、如果是brew安装的openssl

export LDFLAGS="-L/usr/local/opt/openssl/lib"
export CPPFLAGS="-I/usr/local/opt/openssl/include"

3、通过pecl安装swoole

pecl install swoole

 

文章评论